Technical bug reports/issues thread

Usually things go smoothly but sometimes problems happen. I would appreciate knowing about any technical issue or bug on the site, even if it’s small or seems trivial. Maybe it’s a symptom of a bigger problem, or maybe it is happening to a lot of people, or maybe it really is trivial but that’s ok!

Since there’s no other designated place yet, feel free to post any issues here.

Please include:

  • device (mobile, desktop , tablet?)
  • operation system
  • browser
  • approximately when did the issue start?
  • how frequently does the issue occur?


undefined method `calculate_dominant_color!’ for #

I’ve been getting this error when trying to upload .jpg images. Some .jpg upload just fine while others trigger the error.

I converted the images that were causing trouble to other file types like .png and they were coming up with the same error.

1 Like

The site is currently being upgraded to the newest version, that could be the cause. I had the same issue myself about 5 minutes before your post, I’ll investigate more. Thank you for the report


It’s done. Try again and let me know if the problem persists.


Problem is fixed!

Getting a “500 error” message when I try to post.

And this type of error when I upload an image.

“undefined method ‘secure_uploads’ for #<Class:0x00007[bunch of digits and letters]>”

Again, updating hahah. Give it about 5 more minutes

Thanks, pfm! :smiley:

normally when I update like this, it’s virtually seamless but maybe there’s a critical update this time that completely prevents posting briefly

Everything works well now!


There are two types of updates. One is a full shut-down of the site and rebuild. There’s another kind that lets me update while the site is still running. I think it works by building another copy of the forum while the current one is running and then swaps it out when it’s done.

The latter is usually seamless. I think there are a few more major updates being built up to though and it probably affects some core functionality which is why there was a problem briefly this time.


I haven’t been able to upload images from my phone for the past couple days, they’ll start uploading then the page will refresh and they’re stuck uploading forever

1 Like

Thanks for the report. What phone/browser are you using?

Does anyone else have this problem?

Testing from my phone

I’m on ios using safari

Ive asked a few other iphone users and they don’t seem to have a similar issue so it’s probably something specific on your end. What iphone do you have and if possible which version of safari? Do you have the same issue on wifi vs data?

Are the photos saved to the device or icloud?


It’s an iPhone 8 and they’re saved to the device



Huh ok, I turned off wifi and it worked

1 Like

are you at work or a place with some kind of firewall/limitation?

1 Like

No but I just tested with wifi again and it worked so I don’t know what was going on, guess it was just something on my end fucking up

1 Like

I try to keep the site frequently so it’s possible a bug was introduced by someone and then immediately fixed between updates. But because the problem only seems to be on your end, it is probably a “just you” problem :slightly_smiling_face:

I appreciate the report though! I can’t fix things if I don’t know that they are broken!

1 Like

Not really important, but noticed count of badges for “favoriting” doesn’t match what I have available. States 0/6 selected as favorites, but I have 8 badges.

Touching/clicking the :star: on that screen will add a badge to your favorites. You have 8 badges but all users can only have up to 6 favourites that will take priority on your user card.

1 Like

Thank you for clarifying!

1 Like